?

Log in

Nov. 16th, 2007 @ 08:21 pm Bartender3 problem - not patch related
I wanted to post this when i first noticed the problem 2 weeks ago but didn't get a chance. I'm hoping someone can point out what I'm overlooking.

I use Bartender3 for my bars and I'm pretty pleased with it. But recently, a problem popped up on all of my characters *except* my druid. I can't use my keyboard to use my attacks. I have the hotkey enabled and all of my settings are the same on *all* characters. This is definitely a Bartender problem, because when I turn off all other mods the problem still exists.

Yes, i'm using the most recent version, but like I said the problem was around before the patch came out.



Here is my druids bar, with working hotkeys



See? The numbers are there and pressing the 4 on my keyboard makes moonfire go kerplow.



This is my mage, same settings across the board (including in Blizz's interface) but now, no numbers are on the buttons and pressing 4 (or any other number) doesn't make anything happen at all. Both characters are using Bar 1 as that bottom bar. I've also tried to delete the profile and remake it as well as deleting the profile and copying my druids and had no luck on either try.



This is particularly annoying because I like to use my keyboard a lot on my warrior. Any help is appreciated :) The main Ace forums didn't have anything noticeable on this issue and I've googled around and the only info I found that was the somewhat the same was a rogue stealthing problem (which my rogue isn't experiencing). But, my googlefu might be off today.
About this Entry
Dood and I
ktknievel:
[User Picture Icon]
From:blu
Date:November 17th, 2007 03:10 am (UTC)
(Permanent Link)
I'm using bartender3 and experiencing no problems as a druid. You did set your keybindings in the normal WoW interface thingie, right? That took me forever to fogure out coming from Bongos. The keybindings got all reset when I updated to the new patch and bartender.
[User Picture Icon]
From:ktknievel
Date:November 17th, 2007 05:19 am (UTC)
(Permanent Link)
Like I said, I'm having NO problems on my druid, but I am on every other character (around 10 other characters). Yep, all WoW interface settings are as they should be.

Everything is the same across all characters as far as settings go.
[User Picture Icon]
From:crack_city
Date:November 17th, 2007 05:36 am (UTC)
(Permanent Link)
I've had this as an on-again-off again problem with Bartender3. Though it seems to happen to me with anyone who has a stance bar (druid, paladin, warrior). :| It goes away on its own eventually, which is just as maddening as when it pops up. So I'm interested to see if anyone has a solution, as well. :|
[User Picture Icon]
From:ktknievel
Date:November 17th, 2007 05:47 am (UTC)
(Permanent Link)
If I get an answer from any other source, I'll let you know! I was actually hoping I would log onto my warrior and notice the hotkeys were usable on her because then I would have known it was stance related. But, no luck.

My druid is the first character I logged on after starting to use Bartender3 a couple of months ago, so maybe that has something to do with it. If all else fails, i'll have to do things the long way and go back to using older versions of the mods and updating one by one to see if one specific update kicked this into happening (which is tough when you use Ace's updater!).
[User Picture Icon]
From:ktknievel
Date:November 17th, 2007 06:00 am (UTC)
(Permanent Link)
"You did set your keybindings in the normal WoW interface thingie, right?"

Forgot to comment on this specifically. I did go into the keybinding and just do the simple bind to keys 1-9 but, it's not sticking. I'll switch from one character to the next and they'll be gone again, even with character specific bindings.

I'll likely do a fresh install of Bartender3 to see if that does the trick.
[User Picture Icon]
From:krymsonrose
Date:December 17th, 2007 06:11 pm (UTC)
(Permanent Link)
In the Bliz keybindings menu, make sure that the character specific box isn't checked if you're tying to set the same keybindings for all toons. I was having the same problem for a while, just reset all keybinding to default, unchecked the 'character specific' button and when I redid the keybindings it sorted out.
[User Picture Icon]
From:ktknievel
Date:December 17th, 2007 06:18 pm (UTC)
(Permanent Link)
This confused me! I posted this a month ago, heh. But, it was good to update to say that the problem was fixed several updates later, so it was within the mod.